pete_auto
Intermediate
Intermediate
Posts: 432
Joined: Tue Jan 25, 2005 6:50 pm
Contact: Send private message

Volume Slider Issue

Sun Apr 26, 2020 4:44 pm

I am having difficulty with the "Overlay-Zone Control" scene. When launched from the Designer on the MyServer PC, the volume slider seems to work fine, and also tracks with the volume up and down presses. However, the slider and volume buttons don't track or sync together from the iPad or Android (they do work individually - i.e. volume up and down buttons work, but slider doesn't synchronize, or vice versa).

I am using MyUI scenese, and have the latest designer, and all support files are up to date. All required ports are also open in the MyServer PC.

FWIW - I see the same behavior from my home PC that I use the Designer from to make changes to the scenes.

Appreciate any ideas to resolve this.

Thanks in advance.

pete_auto
Intermediate
Intermediate
Posts: 432
Joined: Tue Jan 25, 2005 6:50 pm
Contact: Send private message

Re: Volume Slider Issue

Tue May 12, 2020 11:58 am

Any ideas? I am still struggling with this #-o

Thanks

User avatar
DavidL
Founder
Founder
Posts: 11827
Joined: Sat Feb 08, 2003 9:39 am
Location: Metamora, Michigan
Contact: Send private message

Re: Volume Slider Issue

Thu May 28, 2020 2:21 pm

ensure the javascript is the latest. update using latest myDesigner each web template you use.

User avatar
Krumpy
Developer
Developer
Posts: 1409
Joined: Thu Sep 04, 2003 11:17 pm
Location: Minneapolis, Mn
Contact: Send private message

Re: Volume Slider Issue

Mon Jun 01, 2020 6:26 pm

It would be helpful to have more information like which OS, which browser, etc. Like David said, make sure that you refresh your project within the Designer such that the latest scripts.js file gets installed in your project/template.
pete_auto wrote:
Tue May 12, 2020 11:58 am
Any ideas? I am still struggling with this #-o

Thanks

pete_auto
Intermediate
Intermediate
Posts: 432
Joined: Tue Jan 25, 2005 6:50 pm
Contact: Send private message

Re: Volume Slider Issue

Thu Jun 04, 2020 4:57 pm

Dave, Krumpy,

Thanks for your response. Yes, the files are refreshed and seem like they are latest. Just to be sure, I "refreshed" it again today, but getting the same behavior. Looking in the HTML folder, it seems that in the "javascript" folder has the latest date I updated, but inside the folders the files seem to have older dates. I can't tell if this is the way it is supposed to be.

The server is running on Windows 10 PC, and I am displaying the clients on iPad Pro 11 (Safari), as well as Android phone (using Chrome). Still same issue. When launched directly from the Designer on the MyServer PC (default is Chrome), the volume slider seems to work fine, and also tracks with the volume up and down presses. But the slider and volume buttons don't track or sync together from the iPad or Android (they do work individually - i.e. volume up and down buttons work, but slider doesn't synchronize, or vice versa).

Thanks

pete_auto
Intermediate
Intermediate
Posts: 432
Joined: Tue Jan 25, 2005 6:50 pm
Contact: Send private message

Re: Volume Slider Issue

Thu Jun 04, 2020 5:00 pm

I am attaching the screenshots of the Java folders...
Attachments
Javascript Update - Allonis.pdf
(214.43 KiB) Downloaded 9 times

User avatar
DavidL
Founder
Founder
Posts: 11827
Joined: Sat Feb 08, 2003 9:39 am
Location: Metamora, Michigan
Contact: Send private message

Re: Volume Slider Issue

Thu Jun 04, 2020 5:00 pm

What web object are you seeing that on and what version of Safari / Chrome do you see the problem in?

pete_auto
Intermediate
Intermediate
Posts: 432
Joined: Tue Jan 25, 2005 6:50 pm
Contact: Send private message

Re: Volume Slider Issue

Thu Jun 04, 2020 5:25 pm

Dave,

The web object is "Overlay-ZoneControl.html". Volume slider doesn't track / sync with volume up/down buttons.

Android: Version Android 10
Chrome version on Android: 83.0.4103.83

iPad: iOS Version:13.5.1
I don't see a separate version of Safari

Thanks again

User avatar
DaveB
Simply Incredible
Simply Incredible
Posts: 3368
Joined: Sun May 30, 2004 11:57 pm
Location: Mays Landing, NJ
Contact: Send private message

Re: Volume Slider Issue

Fri Jun 05, 2020 9:31 pm

Pete
there must be a variable issue or update issue. I just tested multiple interfaces in both an Apple and Android environment with no issues. The slider tracks with the button presses for volume up and down.
Thanks
Dave Bruner
:shock:

User avatar
DavidL
Founder
Founder
Posts: 11827
Joined: Sat Feb 08, 2003 9:39 am
Location: Metamora, Michigan
Contact: Send private message

Re: Volume Slider Issue

Fri Jun 05, 2020 10:51 pm

not sure which webobject you are using. the overlay_....html is the webpage, not the web object.

If you are using a "vertical slider", (or any), ensure that you are sending values on Release...not continuous. Continuous sends too much data for most devices.

pete_auto
Intermediate
Intermediate
Posts: 432
Joined: Tue Jan 25, 2005 6:50 pm
Contact: Send private message

Re: Volume Slider Issue

Sat Jun 06, 2020 12:42 pm

Dave,

I am not clear what you mean by "send values on release". If this is an option somewhere, I can't find it. I am simply using the standard "myUI.Tablets" and myUI.phones scenes that came with the designer. The slider and vol up/down buttons (in the overlay-zonecontrol) work independently, but don't sync (in other words, if I use the volume up button, volume increases, but slider doesn't move).

If you have some time, perhaps you can remote into my system?

Thanks

pete_auto
Intermediate
Intermediate
Posts: 432
Joined: Tue Jan 25, 2005 6:50 pm
Contact: Send private message

Re: Volume Slider Issue

Wed Jun 24, 2020 3:08 pm

Dave,
I still need help with this issue. Anyway you can look into my system?

Thanks

Return to “myMusic”

Who is online

Users browsing this forum: No registered users and 2 guests