untoself
Newbie
Newbie
Posts: 4
Joined: Tue Aug 15, 2006 6:22 pm
Location: Maryland USA

Server Cannot Find Device in AV Family

Fri Feb 14, 2020 3:19 pm

I am setting up the simplest Allonis installation: myMovies on MPC player, with iPad as the remote control. Haven’t even connected to my TV yet This server is a new PC so this is a new installation of all the components, all on the same server, with no other application. But I cannot get a movie to play. Event log consistently says: Cannot find device in AV family. Would appreciate if you would tell me what I’m overlooking. Thanks.

AV family variables are:
Friendly name: Theater MPC
Driver: AV Driver
Model: MPC Player
Zone: Theatre

State Variables:
Using Zone Theater:
Movies active player variable is set to 1, corresponding to first (and only) row in AV Family
av_activedvr variable also set to 1 (however, when I save, it does not save the ! delimiter)


Watch Cyclestate:
Active player variable also set to 1

Movies app: default player is AV Family

Port 13579 is open for the MPC player

User avatar
DavidL
Founder
Founder
Posts: 11744
Joined: Sat Feb 08, 2003 9:39 am
Location: Metamora, Michigan
Contact: Send private message

Re: Server Cannot Find Device in AV Family

Fri Feb 14, 2020 3:31 pm

http://allonis.com/template-features/pr ... ation.html

Did you turn on port 13579 in MPC? Not talking about the firewall, but MPC app itself.

untoself
Newbie
Newbie
Posts: 4
Joined: Tue Aug 15, 2006 6:22 pm
Location: Maryland USA

Re: Server Cannot Find Device in AV Family

Fri Feb 14, 2020 3:40 pm

Yes, it is open in the MPC app itself.
Thanks,
TR

User avatar
DavidL
Founder
Founder
Posts: 11744
Joined: Sat Feb 08, 2003 9:39 am
Location: Metamora, Michigan
Contact: Send private message

Re: Server Cannot Find Device in AV Family

Fri Feb 14, 2020 4:49 pm

Can you play a movie if chosen directly from MPC to your shared movie folder?

http://allonis.com/template-features/pr ... ation.html

And is AVAgent setup to MPC and running and connecting to myServer?

untoself
Newbie
Newbie
Posts: 4
Joined: Tue Aug 15, 2006 6:22 pm
Location: Maryland USA

Re: Server Cannot Find Device in AV Family

Sat Feb 15, 2020 1:54 pm

Dave, Thanks very much for your response.

When I open MPC, running on the server, I can play a movie. The files and SQL have wide open permissions.
AVAgent runs in the tray directly on the server. It has the path to the MPC (but there’s never anything in its event log even when I turn on logging).

Have never experienced this problems with previous installations. Been working on this for days and no matter what I try the server response is always the same: it recognizes the request from the iPad for the movie, then immediately says it cannot find the device in AV family. I’ve read AllonisDave’s explanation of “New Zones, Watch, Listen, Cyclestates” several times but I must be doing something fundamentally wrong. If I’m understanding correctly, putting the variable in the chosen zone should direct the play request to AVFamily and find the appropriate driver, device etc. One clue that this might not be working right for me is that I do not get drop down options on the iPad interface. So WHERE? doesn’t list zone options. Watch? lists Movies, Netflix, etc. but I have to choose “Movies”, which I think it should know if it was seeing the zone I’m using (Theater). Have two iPads - - one running myUI.Tablets and one running Modern.Tablets. Don’t get the zone, watch options in either interface.

User avatar
DavidL
Founder
Founder
Posts: 11744
Joined: Sat Feb 08, 2003 9:39 am
Location: Metamora, Michigan
Contact: Send private message

Re: Server Cannot Find Device in AV Family

Sat Feb 15, 2020 2:25 pm

hi, Install TeamViewer on the myServer PC and send me PM with the TV ID / password and windows password.

untoself
Newbie
Newbie
Posts: 4
Joined: Tue Aug 15, 2006 6:22 pm
Location: Maryland USA

Re: Server Cannot Find Device in AV Family

Fri Feb 21, 2020 3:08 pm

Problem solved. Dave, thanks for all your help.
TR

Return to “Installation”

Who is online

Users browsing this forum: No registered users and 4 guests