User avatar
spage
Newbie
Newbie
Posts: 21
Joined: Tue Feb 10, 2004 3:11 am
Location: Sydney, Australia
Contact: Send private message

Re: V4 Elk Driver

Wed Dec 23, 2015 5:19 pm

Dave,
I have an interface with my lights and the M1 and was wondering if it is possible to trigger my lights though this plugin?
thanks,
Simon

User avatar
AllonisDave
Founder
Founder
Posts: 11604
Joined: Fri Feb 07, 2003 8:56 am
Location: Newport Beach, CA
Contact: Send private message

Re: V4 Elk Driver

Thu Dec 24, 2015 12:28 pm

What types of lights are connected to the Elk? Z-Wave, UPB, Insteon?

User avatar
spage
Newbie
Newbie
Posts: 21
Joined: Tue Feb 10, 2004 3:11 am
Location: Sydney, Australia
Contact: Send private message

Re: V4 Elk Driver

Sat Dec 26, 2015 6:28 am

Clipsal C-Bus.

User avatar
AllonisDave
Founder
Founder
Posts: 11604
Joined: Fri Feb 07, 2003 8:56 am
Location: Newport Beach, CA
Contact: Send private message

Re: V4 Elk Driver

Sat Dec 26, 2015 11:45 am

Would controlling those lights fall under the Elk PLC command set? The Elk driver has commands for controlling lights through the PLC command set but I don't think we've ever had a customer who was controlling lights via the Elk.

User avatar
spage
Newbie
Newbie
Posts: 21
Joined: Tue Feb 10, 2004 3:11 am
Location: Sydney, Australia
Contact: Send private message

Re: V4 Elk Driver

Sat Dec 26, 2015 6:52 pm

No the ELK uses ASCII Protocol commands to communicate with CBUS.
On, OFF and set to xx%.
Thanks,
Simon

User avatar
AllonisDave
Founder
Founder
Posts: 11604
Joined: Fri Feb 07, 2003 8:56 am
Location: Newport Beach, CA
Contact: Send private message

Re: V4 Elk Driver

Mon Dec 28, 2015 9:12 pm

Is that defined in ElkRP somewhere. Can you show an example?

User avatar
spage
Newbie
Newbie
Posts: 21
Joined: Tue Feb 10, 2004 3:11 am
Location: Sydney, Australia
Contact: Send private message

Re: V4 Elk Driver

Tue Dec 29, 2015 12:54 am

It's setup by importing the CBUS config file in ELKRP under Automation/Lighting. (ElkRP1.jpg)
ElkRP2.jpg is what it looks like once imported.
I include the manual for the interface and a copy of my CBUS config file, Owen.xml.

Simon
Attachments
OWEN.zip
CBUS config file zipped
(5.45 KiB) Downloaded 132 times
Interface Manual.pdf
(1.11 MiB) Downloaded 114 times
ElkRP2.JPG
ElkRP2.JPG (141.31 KiB) Viewed 2878 times
ElkRP1.JPG
ElkRP1.JPG (74.7 KiB) Viewed 2878 times

Art Dustman
Expert
Expert
Posts: 614
Joined: Fri Nov 10, 2006 3:22 pm
Location: NJ
Contact: Send private message

Re: V4 Elk Driver

Mon Feb 29, 2016 9:37 am

CinemarDave wrote:Working on your system right now.
Back to the same problem with Climate1 and Climate2

From 12/22/15

Dave, you fixed the driver I believe for the ELk because it wasn't playing nice with the Nest and "Climate 1" and "Climate 2" - see the thread above for the date. I had to completely restart my server and reload everything. Unfortunately I updated all the drivers and the ELk driver shows a file date in July but this problem was fixed in December. Can you put the updated driver(s) in installation agent? [-o<

Art Dustman
Expert
Expert
Posts: 614
Joined: Fri Nov 10, 2006 3:22 pm
Location: NJ
Contact: Send private message

Re: V4 Elk Driver

Wed Mar 02, 2016 9:21 pm

Dave, I know you have a bunch going on. I updated everything and noticed the: Climate|xxx~Fan~Cycle does nothing in the ELK for climate control and Climate|xxx~Fan~Off is missing for some reason as a command. Climate|xxx~Fan~On does work.

Thanks

User avatar
AllonisDave
Founder
Founder
Posts: 11604
Joined: Fri Feb 07, 2003 8:56 am
Location: Newport Beach, CA
Contact: Send private message

Re: V4 Elk Driver

Thu Mar 03, 2016 8:37 pm

The driver supports Fan~on and Fan~off. Not sure why on would work and not off. What was in the log? Cycle is not supported.

Art Dustman
Expert
Expert
Posts: 614
Joined: Fri Nov 10, 2006 3:22 pm
Location: NJ
Contact: Send private message

Re: V4 Elk Driver

Sat Mar 05, 2016 11:13 am

Capture3-5.PNG
Capture3-5.PNG (10.78 KiB) Viewed 2851 times
It dislikes the off command in the ELk driver.

Art Dustman
Expert
Expert
Posts: 614
Joined: Fri Nov 10, 2006 3:22 pm
Location: NJ
Contact: Send private message

Re: V4 Elk Driver

Sat Mar 05, 2016 11:14 am

Since the command builder has no "Off" command listed, I'm assuming the xml for the command is not there.

User avatar
AllonisDave
Founder
Founder
Posts: 11604
Joined: Fri Feb 07, 2003 8:56 am
Location: Newport Beach, CA
Contact: Send private message

Re: V4 Elk Driver

Thu Mar 10, 2016 5:05 pm

Sorry, in Elk the Fan only accepts On, Auto, Toggle. There is no true Off state. I suppose I could alias "Off" to "Auto"

Art Dustman
Expert
Expert
Posts: 614
Joined: Fri Nov 10, 2006 3:22 pm
Location: NJ
Contact: Send private message

Re: V4 Elk Driver

Thu Mar 10, 2016 5:46 pm

Toggle would work. I don't think it currently work though. I'll test it

Return to “MLServer 4 Device Drivers”

Who is online

Users browsing this forum: No registered users and 3 guests