Art Dustman
Expert
Expert
Posts: 614
Joined: Fri Nov 10, 2006 3:22 pm
Location: NJ
Contact: Send private message

Re: Mi Casa Verde Vera Device Driver

Sat Mar 21, 2015 11:32 am

After much messing around, I am unable to get all my devices to show in the driver. I run this: http://192.168.1.100:3480/data_request? ... format=xml and it is showing all the devices. I think there is some other intervention needed... :wink:

I see duplicate items in family manager
Some items in family manager don't show a device in the driver itself
Several lights and devices don't show at all, although the vera is saying they are there per the XML

What happened you ask..? The Vera update failed, and I had to restore to a NEW vera since the original is still not recoverable. Is the ML driver ignoring these because it thinks they are already there and not re-adding them back in? I would like to not lose my lighting id's and others if possible since I would have to rework my scenes. But I'll take working at this point.

User avatar
AllonisDave
Founder
Founder
Posts: 11604
Joined: Fri Feb 07, 2003 8:56 am
Location: Newport Beach, CA
Contact: Send private message

Re: Mi Casa Verde Vera Device Driver

Sat Mar 21, 2015 12:05 pm

Your Vera may have rearranged its IDs. In family manager delete all existing Vera devices from all family trees. Then have the Vera do a full resync. Do all the devices come back? No? Then you will have to generate an xml dump of the Vera and email that to me along with the names of the devices it is not finding. Then I can examine the xml to see what has changed.

Art Dustman
Expert
Expert
Posts: 614
Joined: Fri Nov 10, 2006 3:22 pm
Location: NJ
Contact: Send private message

Re: Mi Casa Verde Vera Device Driver

Sat Mar 21, 2015 4:55 pm

They didn't come back, just scenes. Emailed you a file

Art Dustman
Expert
Expert
Posts: 614
Joined: Fri Nov 10, 2006 3:22 pm
Location: NJ
Contact: Send private message

Re: Mi Casa Verde Vera Device Driver

Sat Mar 21, 2015 5:02 pm

Just noticed this in the event log for the driver: ParseBuffer - Error at ParseBuffer at line #1154 - Object reference not set to an instance of an object

User avatar
AllonisDave
Founder
Founder
Posts: 11604
Joined: Fri Feb 07, 2003 8:56 am
Location: Newport Beach, CA
Contact: Send private message

Re: Mi Casa Verde Vera Device Driver

Sat Mar 21, 2015 5:05 pm

All because the format of the XML being returned has changed. Will need to modify the driver to compensate. What Vera firmware are you running?

User avatar
AllonisDave
Founder
Founder
Posts: 11604
Joined: Fri Feb 07, 2003 8:56 am
Location: Newport Beach, CA
Contact: Send private message

Re: Mi Casa Verde Vera Device Driver

Sat Mar 21, 2015 5:46 pm

Just posted an updated driver that compensates for the xml change. The xml file you sent me imports correctly here. Let me know what happens to you?

Art Dustman
Expert
Expert
Posts: 614
Joined: Fri Nov 10, 2006 3:22 pm
Location: NJ
Contact: Send private message

Re: Mi Casa Verde Vera Device Driver

Sat Mar 21, 2015 6:03 pm

Its the second newest firmware 1.7.513 - this is the version it started happening. The xml header shows the version if you need to make a switch based on versions. I'm scared to run the next one yet.

Art Dustman
Expert
Expert
Posts: 614
Joined: Fri Nov 10, 2006 3:22 pm
Location: NJ
Contact: Send private message

Re: Mi Casa Verde Vera Device Driver

Sat Mar 21, 2015 6:17 pm

Works. Thanks! I like the Vera, but these guys at MCV are killin me.

User avatar
colhemm
Member
Member
Posts: 58
Joined: Sat Aug 06, 2005 7:23 pm
Location: UK
Contact: Send private message

Re: Mi Casa Verde Vera Device Driver

Thu Jun 18, 2015 5:09 pm

Hi Dave,
Been playing around with my Vera Edge with Main Lobby for Android and really like it. When connected every thing came up ok in MLServer, but when i go to the Lights page in Main Lobby for Android only one light appeared. I have just for testing put some in manually and they work great. The only thing i cant work out is the dimming of a light with the slider, what do i put in the command settings.

Thanks
Colin

User avatar
AllonisDave
Founder
Founder
Posts: 11604
Joined: Fri Feb 07, 2003 8:56 am
Location: Newport Beach, CA
Contact: Send private message

Re: Mi Casa Verde Vera Device Driver

Thu Jun 18, 2015 8:24 pm

Are you creating a manual slider for the light? If yes then the command would be

Lighting|<<id>>~Level~{{value}} and the server variable for the slider would be {{lighting_<<id>>_level}}

What models names are being assigned to the vera lights? In order to have them show up in the auto-generated lists they would have to be one on "switch, dimmer, scene"

User avatar
colhemm
Member
Member
Posts: 58
Joined: Sat Aug 06, 2005 7:23 pm
Location: UK
Contact: Send private message

Re: Mi Casa Verde Vera Device Driver

Mon Jun 22, 2015 4:28 pm

This is what i see in MLServer.
vera codes.jpg
vera codes.jpg (91.93 KiB) Viewed 2524 times

User avatar
AllonisDave
Founder
Founder
Posts: 11604
Joined: Fri Feb 07, 2003 8:56 am
Location: Newport Beach, CA
Contact: Send private message

Re: Mi Casa Verde Vera Device Driver

Mon Jun 22, 2015 4:47 pm

For those lights that are dimmable change the model from Switch to Dimmer and then the lighting scene will automatically show the sliders.

User avatar
colhemm
Member
Member
Posts: 58
Joined: Sat Aug 06, 2005 7:23 pm
Location: UK
Contact: Send private message

Re: Mi Casa Verde Vera Device Driver

Mon Jun 22, 2015 4:58 pm

But nothing appears at all in the Light scene.

User avatar
AllonisDave
Founder
Founder
Posts: 11604
Joined: Fri Feb 07, 2003 8:56 am
Location: Newport Beach, CA
Contact: Send private message

Re: Mi Casa Verde Vera Device Driver

Mon Jun 22, 2015 5:59 pm

MainLobby Flash client or web apps.

User avatar
colhemm
Member
Member
Posts: 58
Joined: Sat Aug 06, 2005 7:23 pm
Location: UK
Contact: Send private message

Re: Mi Casa Verde Vera Device Driver

Mon Jun 22, 2015 6:10 pm

Web apps, and im using the Vera Edge.

Return to “MLServer 4 Device Drivers”

Who is online

Users browsing this forum: No registered users and 1 guest