User avatar
Krumpy
Developer
Developer
Posts: 1409
Joined: Thu Sep 04, 2003 11:17 pm
Location: Minneapolis, Mn
Contact: Send private message

Command Syntax

Fri Sep 29, 2006 12:39 am

Also, the command syntax depicted in the product is simply:

MLServeCMD.MLSpeak|text to speak

User avatar
AccessHA
Expert
Expert
Posts: 651
Joined: Sun Feb 13, 2005 8:44 pm
Location: MI
Contact: Send private message

Fri Sep 29, 2006 11:26 am

I haven't tried it yet but can the "text to speak" be a variable as well as plain text?
Hell-bent on automating everything! I’m too lazy to do anything else.

www.accessHA.com
Access Home Automation
The ultimate Insteon resource on the web.

mcascio

Fri Sep 29, 2006 12:22 pm

Yup - just tried it - works great.

MLServeCmd.MLSpeak|Sunrise is at {{mlweather_sunrise}}

mcascio

Fri Sep 29, 2006 12:29 pm

Here's a nice command for the WAF. Just create a button to read the weather info to you in the morning, noon or night:

MLServeCmd.MLSpeak|The temperature outside is {{mlweather_currenttemp}} degrees and feels like {{mlweather_feelslike}} degrees - It is {{mlweather_temp_description}} with wind speeds reaching {{mlweather_wind_speed}} miles per hour.

User avatar
AccessHA
Expert
Expert
Posts: 651
Joined: Sun Feb 13, 2005 8:44 pm
Location: MI
Contact: Send private message

Fri Sep 29, 2006 2:33 pm

I like the weather botton!

I tried the following in MLCallerID 3 but it doesn't appear to work:

MLServeCmd.MLSpeak|Incoming call from {{mlcallerid_lastcall_telephonenumber_001}}
Hell-bent on automating everything! I’m too lazy to do anything else.

www.accessHA.com
Access Home Automation
The ultimate Insteon resource on the web.

mcascio

Fri Sep 29, 2006 2:48 pm

Can you elaborate what didn't work?
Did the command reach MLServer?
Did it speak at all?
Did it say the {{ instead of the actual variable?

User avatar
AccessHA
Expert
Expert
Posts: 651
Joined: Sun Feb 13, 2005 8:44 pm
Location: MI
Contact: Send private message

Fri Sep 29, 2006 4:23 pm

MLCallerID doesn't appear to be triggering the command. I placed the above command in the “Send MLServeCmd on Incoming Call” field. I’ve tried a “change scene” command in this field as well but that doesn’t work. So I suspect it’s an MLCallerID issue.
Last edited by AccessHA on Sat Sep 30, 2006 1:06 am, edited 1 time in total.
Hell-bent on automating everything! I’m too lazy to do anything else.

www.accessHA.com
Access Home Automation
The ultimate Insteon resource on the web.

dr.frazier
Senior Member
Senior Member
Posts: 229
Joined: Sat Oct 15, 2005 11:27 pm
Contact: Send private message

Sat Sep 30, 2006 12:12 am

ditto on the callerID not sending the mlservecmd to mlserver. In the mlserver logs it says processing with a blank line.

dr.frazier
Senior Member
Senior Member
Posts: 229
Joined: Sat Oct 15, 2005 11:27 pm
Contact: Send private message

Mon Oct 02, 2006 3:32 pm

works now with latest release of mlcallerid and mlnetcallerid

very nice

Randy

User avatar
AccessHA
Expert
Expert
Posts: 651
Joined: Sun Feb 13, 2005 8:44 pm
Location: MI
Contact: Send private message

Mon Oct 02, 2006 6:15 pm

Where did you find the latest release?
Hell-bent on automating everything! I’m too lazy to do anything else.

www.accessHA.com
Access Home Automation
The ultimate Insteon resource on the web.

dr.frazier
Senior Member
Senior Member
Posts: 229
Joined: Sat Oct 15, 2005 11:27 pm
Contact: Send private message

Tue Oct 03, 2006 11:44 pm

They have pulled it for now, but the link was halfway down the netcallerID announcement thread in the netcallerID forum

Randy

User avatar
DavidL
Founder
Founder
Posts: 11827
Joined: Sat Feb 08, 2003 9:39 am
Location: Metamora, Michigan
Contact: Send private message

Fri Jul 27, 2007 9:42 am


Return to “MLSpeak”

Who is online

Users browsing this forum: No registered users and 1 guest